BearerยทBasic ์ธ์ฆ ํค๋ ์์ฑ๊ธฐ ์ฌ์ฉ๋ฒ
์คํด์ ๊ณ ๋ฅด๊ณ ๊ฐ์ ๋ฃ์ผ๋ฉด Authorization ํค๋ ํ ์ค๊ณผ ๊ทธ๋๋ก ์คํํ ์ ์๋ curl ์์๋ฅผ ๋ง๋ค์ด ์ค๋๋ค. Bearer ๋ ์๋ฒ๊ฐ ๋ฐ๊ธํ ํ ํฐ์ ๊ทธ๋๋ก ๋ถ์ด๊ณ , Basic ์ ์์ด๋์ ๋น๋ฐ๋ฒํธ๋ฅผ base64 ๋ก ์ธ์ฝ๋ฉํฉ๋๋ค. ์๋ ๋๋๋ฆฌ๊ธฐ ์นธ์ base64 ๋ฅผ ๋ฃ์ผ๋ฉด ์์ด๋์ ๋น๋ฐ๋ฒํธ๊ฐ ๊ทธ๋๋ก ๋๋ฌ๋๋ ๊ฒ๋ ํ์ธํ ์ ์์ต๋๋ค.
์์ฑ ๋ฐฉ์๊ณผ ๊ทผ๊ฑฐ
ํค๋ ํ์์ HTTP ์ธ์ฆ์ ์ ์ํ RFC 9110, Basic ์ธ์ฆ์ RFC 7617, Bearer ๋ RFC 6750 ์ ๊ตฌ์กฐ๋ฅผ ๋ฐ๋ฆ ๋๋ค. ์คํด ์ด๋ฆ์ RFC 9110 ์ token ๋ฌธ์๋ง ํ์ฉํ๊ณ ์ด๊ธ๋๋ฉด ๋ฐ๋ คํฉ๋๋ค. Basic ์ ๋ฐ์ดํธ ๋ณํ์ UTF-8 ๋ก ํ๋ฉฐ, ๋ฌธ์ ์งํฉ์ด ๊ท๊ฒฉ์ ๋ชป ๋ฐํ ์์ง ์์ ์๋ฒ๊ฐ ๋ค๋ฅธ ์งํฉ์ ๊ธฐ๋ํ๋ฉด ๊ฐ์ด ๋ฌ๋ผ์ง๋๋ค. 2026๋ 10์ ๊ธฐ์ค์ ๋๋ค.
ํ๊ณ์ ์ฃผ์์ฌํญ
base64 ๋ ์ํธํ๊ฐ ์๋๋ผ ๋๊ตฌ๋ ๋๋๋ฆด ์ ์๋ ์ธ์ฝ๋ฉ์ ๋๋ค. ๋ฐ๋์ HTTPS ์์์๋ง ๋ณด๋ด๊ณ , ์์ฑํ ํค๋๋ ๋น๋ฐ๋ฒํธ์ ๊ฐ์ ์ทจ๊ธ์ ํ์ธ์. ์ด ๋๊ตฌ๋ ํ ํฐ์ ๋ฐ๊ธํ๊ฑฐ๋ ์๋ฒ์ ์์ฒญ์ ๋ณด๋ด์ง ์์ผ๋ฉฐ, ์๋ฒ๊ฐ ํด๋น ์คํด์ ๋ฐ๋์ง๋ ํ์ธํด ์ฃผ์ง ์์ต๋๋ค. ๋ชจ๋ ์ฒ๋ฆฌ๋ ๋ธ๋ผ์ฐ์ ์์์ ์ผ์ด๋์ง๋ง ํ๋ฉด์ ๋จ์ ๊ฐ์ ์ง์ฐ๊ธฐ ๋ฒํผ์ผ๋ก ์น์ฐ์๊ธฐ ๋ฐ๋๋๋ค.
์์ฃผ ๋ฌป๋ ์ง๋ฌธ
์๋๋๋ค. base64 ๋ ๋ฐ์ดํธ๋ฅผ ๊ธ์๋ก ์ฎ๊ฒจ ์ ๋ ์ธ์ฝ๋ฉ์ด๋ผ ํค ์์ด ๋๊ตฌ๋ ๋๋๋ฆด ์ ์์ต๋๋ค. ์ด ํ์ด์ง์ ๋๋๋ฆฌ๊ธฐ ์นธ์ผ๋ก ์ง์ ํ์ธํด ๋ณด์ธ์. ๋ณดํธ๋ ์ ์ก ๊ตฌ๊ฐ์ HTTPS ๊ฐ ๋ด๋นํฉ๋๋ค.
ํค๋ ๊ฐ์ ๋น๋ฐ๋ฒํธ๋ ํ ํฐ ๊ทธ ์์ฒด์ ๋๋ค. ์ฝ๋ยท์ด์ยท์ฑํ ์ ๋ถ์ฌ๋ฃ์ผ๋ฉด ์ ์ถ์ด๊ณ , ์ ์ฅ์์ ์ปค๋ฐ๋๋ฉด ์ด๋ ฅ์ ๋จ์ต๋๋ค. ์ฐ๊ณ ๋๋ฉด ์ง์ฐ๊ธฐ ๋ฒํผ์ผ๋ก ํ๋ฉด์์ ์น์ฐ์ธ์.
ํ ํฐ์ ๋ฐ๊ธํ๊ฑฐ๋ ์๋ช ์ ๊ฒ์ฆํ๊ฑฐ๋ ์๋ฒ์ ์์ฒญ์ ๋ณด๋ด์ง ์์ต๋๋ค. ์ ๋ ฅํ ๊ฐ์ผ๋ก ํค๋ ํ ์ค๊ณผ curl ์์๋ฅผ ๋ง๋๋ ๊ฒ๊น์ง๋ง ํฉ๋๋ค.